metasploit是一款开源的安全漏洞检测工具,可以帮助安全和IT专业人士识别安全性问题,验证漏洞的缓解措施,并管理专家驱动的安全性进行评估,提供真正的安全风险情报。

首先在Metesploit官网下载最新的安装包。下载地址:

http://www.metasploit.com/download/

下载之后记得比对校检码,如果校检码不符合,说明安装包在下载过程中损坏,需要重新下载。损坏的安装包在安装的时候会出现has no VFS data的错误。笔者就因为没有比对校检码,导致一直出错。校检码比对方法:打开终端,切换到下载目录,输入命令:sha1sum 安装包 结果类似于

47a56013000dded69956da0a827c910a9ced48c7 metasploit-latest-linux-installer.run

将前面的这串字符串与metasploit官方给出的SHA值比较,如果吻合,说明安装包是完整的。SHA值地址:
本帖隐藏的内容

http://www.metasploit.com/download/verify-download/

然后开始安装

先安装ruby。命令:sudo apt-get install ruby

给予安装包执行(x)权限。sudo chmod u+x 安装包

运行安装包。sudo ./安装包

这时候就会出现安装界面,一直下一步就好了

标签: none

评论已关闭