配置服务端 systemctl start frps
cat > /etc/systemd/system/frps.service << EOF
[Unit]
Description = frps
After = network.target syslog.target
Wants = network.target

[Service]
Type = simple
ExecStart = /usr/local/frp/frps -c /usr/local/frp/frps.ini

[Install]
WantedBy = multi-user.target
EOF


配置客户端systemctl start frpc
cat > /etc/systemd/system/frpc.service << EOF
[Unit]
Description = frpc
After = network.target syslog.target
Wants = network.target

[Service]
Type = simple
ExecStart = /usr/local/frp/frpc -c /usr/local/frp/frpc.ini

[Install]
WantedBy = multi-user.target
EOF

1、编译丰富插件时,建议修改下面两项默认大小,留足插件空间。( x86/64 )
Target Images ---> (16) Kernel partition size (in MB) #默认是 (16) 建议修改 (128)
Target Images ---> (160) Root filesystem partition size (in MB) #默认是 (128) 建议修改 (895)

2、取消samba
Extra packages ---> autosamba (取消选定)

3、支持 iPv6:
Extra packages ---> ipv6helper(选定这个后下面几项自动选择了)
Network ---> odhcp6c
Network ---> odhcpd-ipv6only
LuCI ---> Protocols ---> luci-proto-ipv6
LuCI ---> Protocols ---> luci-proto-ppp

4、打开适用于VMware的VM Tools
Utilities ---> open-vm-tools #打开适用于VMware的VM Tools
Utilities ---> open-vm-tools-fuse #打开适用于VMware的VM Tools

5、勾选的插件
LuCI ---> Applications ---> luci-app-ddns
LuCI ---> Applications ---> luci-app-diskman
LuCI ---> Applications ---> luci-app-filetransfer
LuCI ---> Applications ---> luci-app-firewall
LuCI ---> Applications ---> luci-app-frpc
LuCI ---> Applications ---> luci-app-pptp-server
LuCI ---> Applications ---> luci-app-ttyd
LuCI ---> Applications ---> luci-app-turboacc
LuCI ---> Applications ---> luci-app-turboacc ---> Include Shortcut-FE ECM
LuCI ---> Applications ---> luci-app-turboacc ---> Include BBR CCA
LuCI ---> Applications ---> luci-app-turboacc ---> Include Pdnsd
LuCI ---> Applications ---> luci-app-upnp
LuCI ---> Applications ---> luci-app-webadmin

6、其他插件取消
LuCI ---> Applications ---> luci-app-accesscontrol (取消勾选-访问时间控制)
LuCI ---> Applications ---> luci-app-adbyby-plus (取消勾选-广告过滤)
LuCI ---> Applications ---> luci-app-arpbind (取消勾选-IP/MAC绑定)
LuCI ---> Applications ---> luci-app-autoreboot (取消勾选-支持计划重启)
LuCI ---> Applications ---> luci-app-ipsec-vpnd (取消勾选-IPSEC VPN)
LuCI ---> Applications ---> luci-app-nlbwmon (取消勾选-网络带宽监视器)
LuCI ---> Applications ---> Include ---> rclone-webui (取消勾选-Rclone界面)
LuCI ---> Applications ---> Include ---> rclone-ng (取消勾选-Rclone另一个界面)
LuCI ---> Applications ---> luci-app-unblockmusic(取消勾选-解锁网易云灰色歌曲3合1新版本)
LuCI ---> Applications ---> luci-app-unblockmusic ---> UnblockNeteaseMusic Golang Version
LuCI ---> Applications ---> luci-app-uugamebooster(取消勾选-UU网游加速器)
LuCI ---> Applications ---> luci-app-vlmcsd(取消勾选-KMS服务器)
LuCI ---> Applications ---> luci-app-vsftpd(取消勾选-FTP服务器)
LuCI ---> Applications ---> luci-app-wireguard(取消勾选WireGuard状态)
LuCI ---> Applications ---> luci-app-wol(取消勾选-WOL网络唤醒)
LuCI ---> Applications ---> luci-app-xlnetacc(取消勾选-迅雷快鸟)
LuCI ---> Applications ---> luci-app-zerotier(取消勾选-内网穿透 ZeroTier)

7、第一次编译错误输入
export FORCE_UNSAFE_CONFIGURE=1

8、第一次编译完成后修改luci-theme-argon主题(可选)
cd package/lean
rm -rf luci-theme-argon
git clone https://github.com/jerrykuku/luci-theme-argon.git
make menuconfig
make -j1 V=s

9、修改默认主题(可选)
vi feeds/luci/collections/luci/Makefile
luci-theme-bootstrap修改为luci-theme-argon
或执行
sed -i 's/luci-theme-bootstrap/luci-theme-argon/' feeds/luci/collections/luci/Makefile

10、helloword(可选)
echo "src-git helloworld https://github.com/fw876/helloworld" >> feeds.conf.default
echo "src-git passwall https://github.com/xiaorouji/openwrt-passwall" >> feeds.conf.default
cd package/lean
git clone https://github.com/jerrykuku/lua-maxminddb.git
git clone https://github.com/jerrykuku/luci-app-vssr.git
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
make -j8 download V=s
make -j1 V=s

11、nezha(可选)
echo "src-git nezha https://github.com/erope/openwrt_nezha" >> feeds.conf.default

12、passwall(可选)
编译菜单中找不到luci-app-passwall选项
https://github.com/xiaorouji/openwrt-passwall/tree/3aff3af88536227d12fb7206992af64ff21cf4d2/
手动下载2022-03-03 23:55最后更新的luci-app-passwall 放到lede/feeds/passwall目录下面

13、OpenWrt 编译 LuCI -> Applications 添加插件应用说明
https://www.right.com.cn/forum/thread-344825-1-1.html

13、BT
apt update -y &&
apt full-upgrade -y &&
cd /www/lede &&
export GOPROXY=https://goproxy.cn &&
export all_proxy="socks5://user:pass@127.0.0.1:10808" &&
export FORCE_UNSAFE_CONFIGURE=1 &&
git pull &&
./scripts/feeds update -a &&
./scripts/feeds install -a &&
make defconfig &&
make download -j8 &&
make V=s -j$(nproc)

#查看当前内核版本
uname -r
#查看软件库中可下载的内核
sudo apt list | grep linux-generic*

root@iZj6c4qxbpnkg4mw6p5bzeZ:~# sudo apt list | grep linux-generic*

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

linux-generic-hwe-18.04-edge/focal-updates,focal-security 5.4.0.131.131 amd64
linux-generic-hwe-18.04/focal-updates,focal-security 5.4.0.131.131 amd64
linux-generic-hwe-20.04-edge/focal-updates,focal-security 5.15.0.52.58~20.04.20 amd64
linux-generic-hwe-20.04/focal-updates,focal-security 5.15.0.52.58~20.04.20 amd64
linux-generic/focal-updates,focal-security 5.4.0.131.131 amd64 [upgradable from: 5.4.0.47.50]

#下载最新的内核
sudo apt-get install linux-generic/focal-updates

系统支持:CentOS 6+,Debian 7+,Ubuntu 12+
虚拟技术:任意
内存要求:≥128M

关于本脚本:
1、本脚本适用于三大 Linux 发行版,其他版本则不支持。
2、KMS 服务安装完成后会加入开机自启动。
3、默认记录日志,其日志位于 /var/log/vlmcsd.log。

安装方法:
wget --no-check-certificate https://www.wzh.kim/sh/kms/kms.sh && chmod +x kms.sh && ./kms.sh

使用命令:
启动:/etc/init.d/kms start
停止:/etc/init.d/kms stop
重启:/etc/init.d/kms restart
状态:/etc/init.d/kms status

卸载方法:
./kms.sh uninstall

sudo apt update -y &&
sudo apt full-upgrade -y &&
cd /home/ubuntu/lede &&
export GOPROXY=https://goproxy.cn &&
export all_proxy="socks5://127.0.0.1:10808" &&
export FORCE_UNSAFE_CONFIGURE=1 &&
git pull &&
./scripts/feeds update -a &&
./scripts/feeds install -a &&
make defconfig &&
make download -j8 &&
make V=s -j$(nproc)